Go Back   PC Gamer Forums > Tech

    Reply
     
    Thread Tools Display Modes
      #1   Report Post  
    Old 06-30-2010, 03:55 AM
    Mythic Mythic is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: America of States United
    Posts: 910
    Default Weird Problems?

    It's happened with Mass Effect 1/2, Dragon Age: Origins, and Transformers: War for Cybertron.

    NOTE: I wasn't sure how to describe something like this, so I'll put it as best as I can.
    Normally, when you turn a TV on to static, you can see a horizontal line usually crawling it's way down the screen. That's essentially what happens in the game. It makes texts and interface flicker, and persists until you either quit the game, or temporarily remedy it with the solution (mentioned below).

    Usually the symptom is accompanied with ludicrous amounts of lag. Pausing the game, alt-tabbing, and then going back into the game usually solves temporarily, but the problem likes to persist... a lot. I also attribute it as a primary factor of why I've stopped playing ME2.

    At first, I thought it was video settings. Turned the settings down; no go. Problem still showed up. Then, I thought it was my video codes being all screwy again. I'm using the K-Lite Codec Pack, and added them to the exceptions list of the ffdshow codecs (as suggested when I read about it online). Still no go.

    For ME1/2 and DA:O, I'd written it off as Bioware game problems. I posted for help on the forums to no avail. So now that the problem has shown up again, I'm looking for aid to remedy this buggering problem.

    My specs (fairly drab):
    Core 2 Duo e7200
    2 GB RAM
    Nvidia GeForce 8600 GTS
    Windows XP SP3

    And my Forceware drivers are running on "Performance", if that helps.
    Reply With Quote
      #2   Report Post  
    Old 06-30-2010, 12:00 PM
    Decho Decho is offline
    Senior Member
     
    Join Date: Jun 2010
    Posts: 275
    Default

    I used to get this with Battlefield 2142, but I never found a fix as my HDD failed not long after is started happening.
    Reply With Quote
      #3   Report Post  
    Old 06-30-2010, 12:20 PM
    FridgeRaider FridgeRaider is offline
    Junior Member
     
    Join Date: Jun 2010
    Location: Poole, Dorset, UK
    Posts: 27
    Default

    I take it you've tried all of the usual stuff like un/re-installing drivers and re-seating the graphics card? Also check the refresh rate setting in the nvidia control panel - it might be set to something to low/high.

    It might also be a problem with the monitor cable. Check there are no bent pins, etc.

    Last edited by FridgeRaider; 06-30-2010 at 12:22 PM.
    Reply With Quote
      #4   Report Post  
    Old 06-30-2010, 07:20 PM
    Mythic Mythic is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: America of States United
    Posts: 910
    Default

    Quote:
    Originally Posted by FridgeRaider View Post
    I take it you've tried all of the usual stuff like un/re-installing drivers and re-seating the graphics card? Also check the refresh rate setting in the nvidia control panel - it might be set to something to low/high.

    It might also be a problem with the monitor cable. Check there are no bent pins, etc.
    I'd just recently relocated my computer to another room and I'm sure all the wires are clean.

    As for the refresh rate, I'll have to check that out, thanks for the tip.

    EDIT: Everything seems to check out alright. The refresh rate is 60Hz, which is what my monitor is at. So the problem still persists. =\

    Last edited by Mythic; 06-30-2010 at 07:23 PM.
    Reply With Quote
      #5   Report Post  
    Old 06-30-2010, 08:06 PM
    Godl1keStev3 Godl1keStev3 is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: Scotland
    Posts: 267
    Default

    Might sound like a wierd question, but have you installed the drivers correctly for your graphics card?

    I had odd visual disturbances and odd framerate issues when I first got my new pc, took me almost a fortnight to realise windows 7 had updated my gfx card drivers, but NOT installed the control panel software properly. In the end I had to uninstall the drivers and reinstall the ones from the ATI website.

    I would try this anyway, tbh. If it was every game, Id probably say hardware/software issue, but if its just the few (all Unreal 3 Engine stuff too), sounds like a compatibility problem to me.
    Reply With Quote
      #6   Report Post  
    Old 06-30-2010, 10:47 PM
    Mythic Mythic is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: America of States United
    Posts: 910
    Default

    Quote:
    Originally Posted by Godl1keStev3 View Post
    I would try this anyway, tbh. If it was every game, Id probably say hardware/software issue, but if its just the few (all Unreal 3 Engine stuff too), sounds like a compatibility problem to me.
    Well, I already double-checked my drivers (uninstalled and everything), and they work just fine.

    I'm not entirely sure if it's an Unreal Engine problem. I have Splinter Cell: Conviction and Rainbow Six: Vegas 2 (which are also UE games), and they work perfectly fine without a hitch.

    Though, after more testing, I checked back into Transformers and looked at the settings. It was running at 40Hz. I know most games don't really have a function to change the refresh rates on it, but maybe this could be a helpful clue.
    Reply With Quote
      #7   Report Post  
    Old 07-07-2010, 01:21 PM
    eZ` eZ` is offline
    Member
     
    Join Date: Jun 2010
    Posts: 84
    Default

    This sounds like tearing. Check the optimum refresh rate for your monitor, check the refresh rate in games match up to that, and then enable v-sync to see if the problem goes away.

    Another possibility is your card isn't changing it's clock speed correctly when launching a 3D app. Download something like rivatuner and force the card to run at its stock 3D clocks at all times and see if that makes any difference.
    __________________
    With Love,
    STEAM: .../id/ez
    WSGF.com

    Dobalina ... WoW PCG Guild
    Reply With Quote
      #8   Report Post  
    Old 07-07-2010, 02:32 PM
    Ayumis Ayumis is offline
    Senior Member
     
    Join Date: Jun 2010
    Posts: 364
    Default

    I wouldn't think screen tearing would slow the games down but to be sure change your nvidia settings to have vsync on.

    As far as I remember that's what it's called and it should apply to all games or have another setting to force it too.
    Reply With Quote
    Reply

    Thread Tools
    Display Modes

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

    Forum Jump