Go Back   PC Gamer Forums > Tech

    Reply
     
    Thread Tools Display Modes
      #1   Report Post  
    Old 06-15-2013, 02:07 AM
    chainingedee chainingedee is offline
    Junior Member
     
    Join Date: Jun 2013
    Posts: 3
    Default Need advice with building a gaming PC

    I currently play the Xbox 360 and have been wanting to build my own gaming PC, since buying one already built is so freakin expensive. The only problem is that I have no idea where to start. My budget is about 800 - 900 USD and would like some help with equipment to purchase. Any input would be greatly appreciated. I Like to play RPG and FPS, if that helps with the selection of equipment.
    Reply With Quote
      #2   Report Post  
    Old 06-15-2013, 05:11 PM
    MacLeod MacLeod is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: Chattanooga, TN - USA
    Posts: 3,503
    Default

    How about this one for $890?

    [url]http://pcpartpicker.com/p/16GCL[/url]
    __________________
    • AMD FX 8350 @ 4.815 - 1.40V CnQ enabled
    • EVGA GTX 670 FTW @ 1070 (1239 boost)
    • Asus Sabertooth 990FX rev 1
    • Corsair Vengeance 1600MHz 8GB
    • Samsung 840 Evo 250GB SSD
    • Western Digital Blue 1TB x2
    • EVGA Supernova G2 750
    • HP 2509B @ 1920x1080
    • Corsair Carbide 500R
    • Corsair H100
    • BlackWidow Ultimate & DeathAdder
    Reply With Quote
      #3   Report Post  
    Old 06-15-2013, 09:02 PM
    chainingedee chainingedee is offline
    Junior Member
     
    Join Date: Jun 2013
    Posts: 3
    Default

    that looks pretty good, but i have had issues with Western Digital products before. Not sure if its just me but are they reliable?
    Reply With Quote
      #4   Report Post  
    Old 06-15-2013, 09:41 PM
    MacLeod MacLeod is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: Chattanooga, TN - USA
    Posts: 3,503
    Default

    All manufacturers can put out a turd now and then. Both Western Digital and Seagate are good manufacturers and Id use either of them but Ive just always had better luck with WD. I just recently retired a rig that was running an 80GB WD drive from 2001 and it was still running just fine. Thats all Ive used and Ive yet to have a problem so I stick with them. So its more of a brand preference than actual empirical data.

    If you feel more comfortable with Seagate then by all means go that way. Im sure it will be just fine.
    __________________
    • AMD FX 8350 @ 4.815 - 1.40V CnQ enabled
    • EVGA GTX 670 FTW @ 1070 (1239 boost)
    • Asus Sabertooth 990FX rev 1
    • Corsair Vengeance 1600MHz 8GB
    • Samsung 840 Evo 250GB SSD
    • Western Digital Blue 1TB x2
    • EVGA Supernova G2 750
    • HP 2509B @ 1920x1080
    • Corsair Carbide 500R
    • Corsair H100
    • BlackWidow Ultimate & DeathAdder

    Last edited by MacLeod; 06-15-2013 at 11:18 PM.
    Reply With Quote
      #5   Report Post  
    Old 06-15-2013, 10:02 PM
    Orkgutz Orkgutz is offline
    Senior Member
     
    Join Date: Jun 2010
    Location: England
    Posts: 1,469
    Default

    WD are fine, as MacLeod says, every company will put out some faulty goods. I use 2 WD 1TB Caviar Blues and they're absolutely fine
    __________________
    Zalman Z9 Plus
    Intel Core i5 2500k @4.2Ghz
    Cooler Master Hyper 212 EVO - Corsair SP120 x2 in Push/Pull
    MSI Z77A-GD55
    VTX3D 7870 Tahiti LE
    8GB Crucial Ballistix 1600Mhz
    Kingston HyperX 120GB SSD
    Western Digital SATAIII 1TB x2
    Corsair GS700w

    My Blog

    My Steam
    Reply With Quote
      #6   Report Post  
    Old 06-20-2013, 12:34 AM
    chainingedee chainingedee is offline
    Junior Member
     
    Join Date: Jun 2013
    Posts: 3
    Default

    ok, awesome. thanks guys. I'll definitely use your build Macleod as a base.
    Reply With Quote
    Reply

    Tags

    build, help is needed

    Thread Tools
    Display Modes

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

    Forum Jump