Go Back   PC Gamer Forums > Tech

     
     
    Thread Tools Display Modes
    Prev Previous Post   Next Post Next
      #1   Report Post  
    Old 06-15-2013, 04:07 PM
    TacticalPete44 TacticalPete44 is offline
    Junior Member
     
    Join Date: Jun 2013
    Posts: 6
    Default New to PC Gaming, Build Troubleshoot.

    I built my first gaming computer this past week with the help of a friend. I am encountering some issues that he can't seem to fix, however.

    First, build specs: AMD A10 6800K 41.GHz quad core CPU, 2x 8GB DDR3 1866 Ballistix RAM, an ASRock FM2 A85X Extreme 6 motherboard, a Gigabyte HD 7970 3gig Gddr5 Windforce graphics card, a corsair 1050 Professional power supply, all in a NZXT Phantom 630 full tower and running windows 7 hope premium 64 bit.

    My monitor is a 27 inch Acer running at 1920 x 1080.

    I have tried to make sure every component has fully up-to-date drivers installed.

    The problem: Battlefield 3 (and bioshock infinite), if run on ultra, get HORRIBLE framerate.

    Last night I was actually playing Bioshock Infinite and running it on High and if there were any enemies, the games frame rate dropped considerably, making it impossible to aim or anything.

    Anyways, I'm not sure how to proceed... so any help will be much appreciated.

    Thanks,

    Pete

    Last edited by TacticalPete44; 06-15-2013 at 04:31 PM.
    Reply With Quote
     

    Thread Tools
    Display Modes

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

    Forum Jump