Go Back   PC Gamer Forums > Play with PC Gamer > Planetside 2 > Planetside 2 UK

    Reply
     
    Thread Tools Display Modes
      #21   Report Post  
    Old 11-21-2012, 02:34 PM
    Adsy Adsy is offline
    Junior Member
     
    Join Date: Nov 2012
    Posts: 8
    Default

    I don't think it's bugs that are the issue but the server load. the final days of the beta were pretty smooth for me. Unless they've made the classic mistake of using an "older build"... *sigh*
    Reply With Quote
      #22   Report Post  
    Old 11-21-2012, 07:12 PM
    aneesh99 aneesh99 is offline
    Member
     
    Join Date: Aug 2010
    Location: Caaaaaaardiff
    Posts: 74
    Default

    In queue as we speak, only 250 people left ahead of me! SpiralZero TR
    __________________
    AMD Phenom II X6 1090T @ 4.0GHz | Coolermaster Hyper 212 Evo | MSI 7950 TFIII OC BE 1200/1575 | Asus M4A89GTD Pro/USB3 | GSkill Ripjaw 8GB DDR3 1600MHz | Samsung Spinpoint F3 1TB | Corsair TX750V2 | Thermaltake V5 | Dell U2312HM |
    Reply With Quote
      #23   Report Post  
    Old 11-22-2012, 08:32 AM
    Adsy Adsy is offline
    Junior Member
     
    Join Date: Nov 2012
    Posts: 8
    Default

    i bought that membership thing and even though the "plebs" queue was 550 the "MPs" queue was only 12...

    it was sooooo laggy though, it was unplayable for me. i'd see an enemy soldier sort of blip in and out of view and try to shoot where i'd seen but then i;d die, as i'm probably perfectly visible. also died on numerous occassions inside the base spawn room, where i might add, that enemies can't even shoot into. must have been bullet hits registering before I died and catching up on my newly made clone. sucks tbh. I think they've set the server caps too high... will give it another try tonight.
    Reply With Quote
    Reply

    Thread Tools
    Display Modes

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

    Forum Jump