PC Gamer Forums

PC Gamer Forums (http://www.pcgamer.com/forum/index.php)
-   Wurm Online (http://www.pcgamer.com/forum/forumdisplay.php?f=23)
-   -   Help! (http://www.pcgamer.com/forum/showthread.php?t=5268)

Rush 12-24-2010 10:17 PM

Please can someone help.

I recently downloaded Wurm, I waited for the client to download some stuff and when I tried to play the game just crashed as soon as it loaded.

I tried again and again but I just cannot get it working.

I'd love to play this game, oh and before I forget here is the error log thingy it left in my downloads folder.

*The Error log is too long to post :(
But here is the first part of it.
--------------- T H R E A D ---------------

Current thread (0x3cb99400): JavaThread "Wurm 2.7.5g main thread" [_thread_in_native, id=2384, stack(0x3e440000,0x3e490000)]

siginfo: ExceptionCode=0xc0000005, reading address 0x5a881000

EAX=0x5aaa0020, EBX=0x5a7c0020, ECX=0x000007e1, EDX=0x00000000
ESP=0x3e48f570, EBP=0x3e48f578, ESI=0x5a880fa0, EDI=0x5ab60fa0
EIP=0x69be2cd8, EFLAGS=0x00010206

Register to memory mapping:

0x5aaa0020 is pointing to unknown location

0x5a7c0020 is pointing to unknown location

0x000007e1 is pointing to unknown location

0x00000000 is pointing to unknown location

0x3e48f570 is pointing into the stack for thread: 0x3cb99400
"Wurm 2.7.5g main thread" prio=6 tid=0x3cb99400 nid=0x950 runnable [0x3e48f000]
java.lang.Thread.State: RUNNABLE

0x3e48f578 is pointing into the stack for thread: 0x3cb99400
"Wurm 2.7.5g main thread" prio=6 tid=0x3cb99400 nid=0x950 runnable [0x3e48f000]
java.lang.Thread.State: RUNNABLE

0x5a880fa0 is pointing to unknown location

0x5ab60fa0 is pointing to unknown location

Top of Stack: (sp=0x3e48f570)
0x3e48f570: 00100000 00000000 3e48f5a8 69be2d61
0x3e48f580: 5aaa0020 5a7c0020 00100000 00000000
0x3e48f590: 00000000 3e48f67c 5a7c0020 00100000
0x3e48f5a0: 4165dd38 5a7c0020 00000000 699c6c86
0x3e48f5b0: 5aaa0020 5a7c0020 00100000 00000045
0x3e48f5c0: 00000200 00000000 69961b9a 00000200
0x3e48f5d0: 00000001 00000000 00000045 00000000
0x3e48f5e0: 5a7c0020 00000000 00000000 00000000

Instructions: (pc=0x69be2cd8)
0x69be2cc8: 20 66 0f 7f 5f 30 66 0f 6f 66 40 66 0f 6f 6e 50
0x69be2cd8: 66 0f 6f 76 60 66 0f 6f 7e 70 66 0f 7f 67 40 66

Stack: [0x3e440000,0x3e490000], sp=0x3e48f570, free space=317k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [atioglxx.dll+0xbb2cd8]
C [atioglxx.dll+0xbb2d61]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j com.sun.opengl.impl.GLImpl.glCopyTexSubImage2D(III IIIII)V+0
j class.eT.a(Lclass/bd;Lclass/bd;)V+1004
j class.gA.a(ILclass/bd;Lclass/bd;)V+1607
j class.dq.a(ILclass/bd;Lclass/bd;)V+101
j class.dq.a(II)V+102
j com.wurmonline.client.f.d(Ljavax/media/opengl/GL;)V+936
j com.wurmonline.client.f.run()V+526
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
0x3cb9c400 JavaThread "Thread-24" [_thread_in_Java, id=1904, stack(0x4ef30000,0x4ef80000)]
0x3cb9c000 JavaThread "Thread-23" [_thread_blocked, id=5384, stack(0x46a00000,0x46a50000)]
0x3cb9b400 JavaThread "Thread-22" [_thread_in_Java, id=824, stack(0x46650000,0x466a0000)]
0x3cb98800 JavaThread "Thread-21" [_thread_blocked, id=5556, stack(0x41d50000,0x41da0000)]
0x3cb9b800 JavaThread "Keep-Alive-Timer" daemon [_thread_blocked, id=4832, stack(0x41ec0000,0x41f10000)]
0x3cb99000 JavaThread "Wurm-Fast-Clock-Workaround-Thread" daemon [_thread_blocked, id=5012, stack(0x41e70000,0x41ec0000)]
0x3cb9a800 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=2680, stack(0x3ffa0000,0x3fff0000)]
=>0x3cb99400 JavaThread "Wurm 2.7.5g main thread" [_thread_in_native, id=2384, stack(0x3e440000,0x3e490000)]
0x3cb9ac00 JavaThread "AWT-Shutdown" [_thread_blocked, id=4804, stack(0x3e310000,0x3e360000)]
0x3cb97c00 JavaThread "XSI Model Loader 1" daemon [_thread_blocked, id=3420, stack(0x3d370000,0x3d3c0000)]
0x3cb9a000 JavaThread "XSI Model Loader 0" daemon [_thread_blocked, id=6108, stack(0x3d020000,0x3d070000)]
0x3cb98400 JavaThread "TimerQueue" daemon [_thread_blocked, id=3096, stack(0x3df10000,0x3df60000)]
0x3ca48800 JavaThread "CacheCleanUpThread" daemon [_thread_blocked, id=2560, stack(0x3d450000,0x3d4a0000)]
0x3ca46400 JavaThread "CacheMemoryCleanUpThread" daemon [_thread_blocked, id=832, stack(0x3d3c0000,0x3d410000)]
0x023c9c00 JavaThread "DestroyJavaVM" [_thread_blocked, id=4424, stack(0x02240000,0x02290000)]
0x3ca42400 JavaThread "Javaws Secure Thread" daemon [_thread_blocked, id=5308, stack(0x3d290000,0x3d2e0000)]
0x3ca41800 JavaThread "AWT-Windows" daemon [_thread_in_native, id=6028, stack(0x3d240000,0x3d290000)]
0x3ca40c00 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=4624, stack(0x3cf70000,0x3cfc0000)]
0x0238f400 JavaThread "traceMsgQueueThread" daemon [_thread_blocked, id=1900, stack(0x3cbe0000,0x3cc30000)]
0x02370800 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=6008, stack(0x3c8c0000,0x3c910000)]
0x0235c000 JavaThread "CompilerThread0" daemon [_thread_blocked, id=1332, stack(0x3c830000,0x3c880000)]
0x02358c00 JavaThread "Attach Listener" daemon [_thread_blocked, id=5132, stack(0x3c7a0000,0x3c7f0000)]
0x02355c00 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=5420, stack(0x3c710000,0x3c760000)]
0x02328c00 JavaThread "Finalizer" daemon [_thread_blocked, id=4612, stack(0x3c680000,0x3c6d0000)]
0x02327800 JavaThread "Reference Handler" daemon [_thread_blocked, id=2988, stack(0x3c5f0000,0x3c640000)]

Other Threads:
0x02325400 VMThread [stack: 0x3c560000,0x3c5b0000] [id=5108]
0x02382c00 WatcherThread [stack: 0x3c950000,0x3c9a0000] [id=3776]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None

def new generation total 43200K, used 18136K [0x04450000, 0x07320000, 0x14ef0000)
eden space 38464K, 47% used [0x04450000, 0x05606178, 0x069e0000)
from space 4736K, 0% used [0x069e0000, 0x069e0000, 0x06e80000)
to space 4736K, 0% used [0x06e80000, 0x06e80000, 0x07320000)
tenured generation total 95724K, used 57433K [0x14ef0000, 0x1ac6b000, 0x36450000)
the space 95724K, 59% used [0x14ef0000, 0x187065a0, 0x18706600, 0x1ac6b000)
compacting perm gen total 20224K, used 20026K [0x36450000, 0x37810000, 0x3a450000)
the space 20224K, 99% used [0x36450000, 0x377deba0, 0x377dec00, 0x37810000)
No shared spaces configured.


If you need to know any more just tell me :)

BTW. I tried to post this on the wurm forums but the damned thing won't let me register.

M_the_C 12-24-2010 10:54 PM

Sorry to hear you're having problems. I can't be certain without seeing the full error message, and even then I'm no expert in solving these issues, but [URL="http://wurmonline.com/forum/index.php?topic=45832.0"]this thread[/URL] in the official bug forums (your best place to find help) appears to be similar.

In the thread it is suggested that you try disabling colour picking (Settings>Compatibility) and possibly lowering the graphics settings.

Good luck in solving your problem. :)

EDIT: Not sure what your problem would be registering on the official forum, can you see the reCAPTCHA box?

Rush 01-23-2011 03:57 PM

I solved it, if anyone is still wondering how to fix this what i did was : open CCC (catalyst control center) Click Graphics then 3d go to the tab that says "All" Then scroll down until you find "Disable Catalys A.I" Check the box and there, should be ready to play :D

All times are GMT. The time now is 04:08 AM.