Destiny 2's latest hotfix is live and seems to have resolved 'hitching'

The bug was introduced by the previous hotfix

UPDATE 2: Hotfix 1.0.6.2 now walks among us, and from some very limited testing it seems to have removed the 'hitching' that had blighted the game after the previous hotfix. I ran a couple of public events and even with many guardians and enemies throwing down, saw none of the micro-freezes that were happening before. I'll keep an eye on it, but so far so good.

UPDATE 1: Bungie has announced hotfix 1.0.6.2 will roll out on Monday, November 6 (or November 7 in the southern hemisphere). 

Original story:

You know the old saying: if it ain't broke, don't fix it. But if it is broke, make sure you don't break something more important when fixing it. Unfortunately, that seems to be what happened to today when Bungie rolled out a hotfix as part of the 1.0.6 Patch, which was intended to solve the performance degradation being caused by a bug that also means clan rosters were not displayed in-game.

The good news: The clan bug has indeed been resolved. You can now see your clanmates listed in the clan menu, and my performance has remained consistent even after leaving the game running for a couple of hours. However, it is now consistently problematic in a different way. Both James and I are experiencing micro-freezes that last about a second or so, particularly during busy public events. Note that these were not present when playing on the same hardware previously.

A quick glance at the big Destiny 2 community sites reveals many players complaining of the exact same thing. The current most updated post on the Bungie Help forum is titled ''1.0.6.1 Patch Random 1 second Stutters". A Bungie helper has responed saying: "Thank you for your reports. I've begun forwarding information to internal teams for investigation."

Meanwhile the Reddit thread dedicated to the patch is full of PC players describing the issue. A typical comment reads: "Ever since this hotfix, I've been getting very sudden freezes. Every sixty seconds or so, my screen will hang for what feels like maybe 1/10th of a second, just long enough to be noticeable. Before and after, it's silky smooth 60fps. This wasn't happening before today's update."

Hopefully Bungie acknowledges the issue and rolls out another hotfix soon, as it seems odd that something seemingly so easy to spot was shipped. I've asked them for comment. On a more cheery note, the bug that led to public events often being empty has been resolved. The ones I've tried this morning have all had multiple other guardians present. So at least you won't have to be salty on your own.

Bungie Help has tweeted to say they're looking into the issue.

Recent news